Commit 3acdb9e8 authored by Jiří Pudil's avatar Jiří Pudil

Merge branch 'nette-3' into 'master'

Nette 3.0 compatibility

See merge request !1
parents d42dd3ba 711a6da4
......@@ -4,8 +4,8 @@
"type": "library",
"require": {
"php": "~7.1",
"nette/di": "~2.4",
"nette/bootstrap": "~2.4"
"nette/di": "~3.0",
"nette/bootstrap": "~3.0"
},
"require-dev": {
"phpstan/phpstan-shim": "~0.11.0"
......
......@@ -75,10 +75,9 @@ abstract class ScopeExtension extends Nette\DI\CompilerExtension
];
$configurator->onCompile[] = function (Nette\Configurator $configurator, Nette\DI\Compiler $compiler): void {
$compiler->getContainerBuilder()->addDefinition(self::OUTER_CONTAINER_SERVICE_NAME)
$compiler->getContainerBuilder()->addImportedDefinition(self::OUTER_CONTAINER_SERVICE_NAME)
->setType(Nette\DI\Container::class)
->setAutowired(false)
->setDynamic(true);
->setAutowired(false);
};
$parameters = $this->getContainerBuilder()->parameters;
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment